Results 1 to 3 of 3

Thread: EI CHT probes failing

  1. #1
    Member
    Join Date
    Jan 2010
    Location
    Boise, ID
    Posts
    86

    Default EI CHT probes failing

    EI's CHT probes on my 2014 CCSS are failing within 100 hrs. Some less. By failing I mean either intermittent or constant erratic readings. Anyone else experience this?

    Thx!

    Andrew

  2. #2
    Senior Member
    Join Date
    Jul 2015
    Location
    Broken Arrow, OK
    Posts
    600

    Default Re: EI CHT probes failing

    My guess would be that it’s the connections. You should see the connection where the panel wire connects to the larger probe wire just a few inches aft of where the sensor screws into the head.

    The wire used on the sensor wires going to the panel are very thin but the sensor wires are very thick. Vibration can break them quite easily if not supported. the best connector to connect the panel wires to the probe wires is a “barrel connector”. It’s a short, round connector with holes in each end and a set screw in the center. The wires are inserted from each end and crossed in the center and the set screw tightened. Shrink tubing should also be used to cover the connection and also gives some support. It’s quite easy to do.

    The wire used in non-solderable (I think they call it). You can’t solder them together, the solder will not stick no matter what but the barrel connectors work great.

    I suspect that is the problem and not the probes failing.

    10FE2805-1A75-4FE0-A531-78F3B970D152.jpg10FE2805-1A75-4FE0-A531-78F3B970D152.jpg

    Quote Originally Posted by jasimmons View Post
    EI's CHT probes on my 2014 CCSS are failing within 100 hrs. Some less. By failing I mean either intermittent or constant erratic readings. Anyone else experience this?

    Thx!

    Andrew
    Last edited by Daveembry; 04-27-2020 at 05:37 AM.
    Dave Embry
    "You only live once.......but if you do it right.........once is enough."..

  3. #3
    Member
    Join Date
    Jan 2010
    Location
    Boise, ID
    Posts
    86

    Default Re: EI CHT probes failing

    Thx Dave! We'll give that a look.

    Andrew

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •