Results 1 to 2 of 2

Thread: radio noise

  1. #1
    Member
    Join Date
    May 2014
    Location
    United States
    Posts
    94

    Default radio noise

    All of a sudden I have static in my radio. EX with 25 hrs. It goes away when I shut down the right ignition. It's not a spark plug pulsing noise but static. It becomes intermittent after I reduce power. Anyone else ever had this or have an idea of where to start checking? I'm thinking bad ground somewhere.

  2. #2
    Member
    Join Date
    Dec 2015
    Location
    Odessa, Wa.
    Posts
    42

    Default Re: radio noise

    Quote Originally Posted by lbell View Post
    All of a sudden I have static in my radio. EX with 25 hrs. It goes away when I shut down the right ignition. It's not a spark plug pulsing noise but static. It becomes intermittent after I reduce power. Anyone else ever had this or have an idea of where to start checking? I'm thinking bad ground somewhere.
    I have loud popping on my radio. Only when moving. While helping my son build his EX, I was reading the manual on the ignition boxes. It didn't come to me right away but later it dawned on me that I read something in red about how you could get radio noise, and gave suggestions of what would be causing it. So the last time I flew my EX I shut down my mags one at a time and sure enough, my right mag was making the noise. I haven't gotten to my manual yet to trouble shoot the problem yet but i am sure it tells you what to look for. Tom W

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •